Hi there, I’ve encountered a problem with my Vtiger webform after I’ve migrated from 6.0.1 to 6.0.4. It’s not functioning as usual. Thanks god, that the solution from https://forum.vtiger.com/index.php?p=/discussion/comment/1187167 it’s working like charm.

The Problem

The problem is because vtiger_webform database is not structured as it suppose to be after you’ve migrated from older to newer version.

The Solution

Go to your phpmyadmin and enter this SQL code
ALTER TABLE `vtiger_webforms` ADD `captcha` INT( 1 ) NOT NULL DEFAULT '0',
ADD `roundrobin` INT( 1 ) NOT NULL DEFAULT '0',
ADD `roundrobin_userid` VARCHAR( 255 ) NULL ,
ADD `roundrobin_logic` INT( 11 ) NOT NULL DEFAULT '0'

If your vtiger_webform_field table is missing. You have to enter this SQL code

CREATE TABLE `vtiger_webforms_field` (
`id` int(19) NOT NULL AUTO_INCREMENT,
`webformid` int(19) NOT NULL,
`fieldname` varchar(50) NOT NULL,
`neutralizedfield` varchar(50) NOT NULL,
`defaultvalue` varchar(200) DEFAULT NULL,
`required` int(10) NOT NULL DEFAULT '0',
`sequence` INT NULL DEFAULT NULL,
`hidden` INT NULL DEFAULT NULL,
PRIMARY KEY (`id`),
KEY `webforms_webforms_field_idx` (`id`),
KEY `fk_1_vtiger_webforms_field` (`webformid`),
KEY `fk_2_vtiger_webforms_field` (`fieldname`),
CONSTRAINT `fk_1_vtiger_webforms_field` FOREIGN KEY (`webformid`) REFERENCES `vtiger_webforms` (`id`) ON DELETE CASCADE,
CONSTRAINT `fk_3_vtiger_webforms_field` FOREIGN KEY (`fieldname`) REFERENCES `vtiger_field` (`fieldname`) ON DELETE CASCADE
)

Lastly if the webform didn’t capture the submitted data, you may overwrite existing capture.php with this file >>> capture.php at modules/Webforms/capture.php

I hope this solution will help you solve the problem. I’m just trying to make it simple for you because I find out that reading in the forum really time consuming since everyone is giving the solution at the same times.

%d bloggers like this: